Verified Commit 999b9cb4 authored by Arie Peterson's avatar Arie Peterson
Browse files

Update VERSION and CHANGELOG for v0.8.2

parent 20818009
## [0.8.2]
### Features
* Enable metallb prometheus monitoring (!1151)
* Monitor ingress logs for http errors (i.e. 499) (!1166)
* Monitor backup software (!1052)
* set logout endpoints for WordPress, Nextcloud and Grafana (!1082)
* Increase disk size of droplet in upgrade tests (!1088)
* test Nextcloud with helm test (!1014)
* Remove single-sign-on release and upgrade Dashboard to a version that includes the login code (!946)
* Let flux auto-upgrade itself (!964)
* fine-tune container memory requests (!927)
* use upstream zulip-postgres:14 image (!996)
* Add missing-container-metrics (!951)
### Bug fixes
* Grafana dashboard fails to install (!1152)
* Increase health check timeouts (!1106)
* v0.8: Increase disk size of droplet in upgrade tests (!1091)
* resolve "clusters/main/.cluster.env: No such file or directory" (!1086)
* Hydra and Kratos serviceMonitors are failing (!1048)
* additional nextcloud configs (!1042)
* Simplify redundant outgoing_mail config (!983)
* Auto-upgrade of kube-prometheus-stack with flux often fails (!982)
### Upgrades
* update helm release kube-prometheus-stack to v36 (!1185)
* update helm release loki to v2.12.1 (!1190)
* update helm release nextcloud-onlyoffice to v0.9.12 (!1186)
* update helm release wordpress to v0.6.48 (!1184)
* update helm release metallb to v3.0.9 (!1182)
* update helm release mariadb to v11.0.13 (!1181)
* update helm release ingress-nginx to v4.1.4 (!1179)
* update helm release velero to v2.29.8 (!1178)
* Update Zulip image to 5.2-0 (!1105)
* update helm release missing-container-metrics to v0.25.0 (!1168)
* update dependency ansible to v5.9.0 (!1167)
* update helm release promtail to v5.1.0 (!1164)
* Upgrade to Flux v0.30.2 (!1155)
* update dependency alpine_edge/kubectl to v1.24.0-r3 (!1153)
* update dependency alpine to v3.16 (!1132)
* Upgrade dashboard to chart version 0.2.3 (!1124)
* update dependency paramiko to v2.11.0 (!1099)
* update dependency alpine_3_15/yq to v4.14.1-r2 (!1083)
* update dependency kubernetes to v23.6.0 (!1061)
* update helm release kratos to v0.23.2 (!1058)
* update helm release hydra to v0.23.2 (!1057)
* update alpine packages to v7.80.0-r1 (!1030)
* Update dependency pytest-testinfra to v6.7.0 (!981)
Current application versions:
| Name | Chart | App version |
|---------------------------|---------|-----------------------|
| cert-manager | v1.8.0 | v1.8.0 |
| dashboard | 0.2.3 | 0.2.3 |
| eventrouter | 0.4.0 | 0.3 |
| hydra | 0.23.2 | v1.10.5 |
| ingress-nginx | 4.1.4 | 1.2.1 |
| kratos | 0.23.2 | v0.9.0-alpha.2 |
| kube-prometheus-stack | 35.5.3 | 0.56.3 |
| local-path-provisioner | 0.0.22 | v0.0.22 |
| loki | 2.12.0 | v2.5.0 |
| metallb | 3.0.9 | 0.12.1 |
| missing-container-metrics | 0.25.0 | 0.25.0 |
| nc | 0.8.15 | NC-23.0.3-OO-7.0.1.37 |
| promtail | 5.1.0 | 2.5.0 |
| single-sign-on-database | 11.0.13 | 10.6.8 |
| velero | 2.29.8 | 1.8.1 |
| wekan | 1.1.1 | 5.93 |
| wordpress | 0.6.48 | 5.9.3 |
| zulip | 0.2.1 | 4.7-0 |
### Documentation
* make copy-pasting installation docs easier (!1137)
* document RAM and CPU requirements for each app (!1123)
* Document how to run `occ` nextcloud CLI commands (!1100)
* Add instructions for Importing Nextcloud, Zulip, Wekan and Wordpress (!1090)
### Known issues
* During development of 0.8.2, we sometimes encountered issues with the automatic upgrade process, specifically
## [0.8.1]
### Changed
......@@ -402,7 +489,8 @@ Known issues:
This is the version for the alpha test.
[Unreleased]: https://open.greenhost.net/openappstack/openappstack/-/compare/0.8.1...master
[Unreleased]: https://open.greenhost.net/openappstack/openappstack/-/compare/0.8.2...master
[0.8.2]: https://open.greenhost.net/openappstack/openappstack/-/compare/08.1...0.8.2
[0.8.1]: https://open.greenhost.net/openappstack/openappstack/-/compare/0.8.0...0.8.1
[0.8.0]: https://open.greenhost.net/openappstack/openappstack/-/compare/0.7.0...0.8.0
[0.7.0]: https://open.greenhost.net/openappstack/openappstack/-/compare/0.6.0...0.7.0
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment